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Task 1: Inserting Images 

Copying an image into your website's Root folder 
In order to use an image in your website, you need to first place it inside the root 
folder of the site. If you followed the instructions in Task 2 last week, this will be the 
folder firstsite inside the folder websites, which is inside the My Documents folder.  

1. First, we'll locate some images we want to use for this task. Minimize 
Dreamweaver and on the Windows Desktop, double click on Shortcut to STU (H) 
to open the STU folder, then, inside this folder, double click on the Dreamweaver 
folder.  

2. Inside the Dreamweaver folder, you will find two files called water_lilies.jpg. and 
water_lilies_small.jpg. Click once on one of the files to select it, then choose Edit 
> Copy, or press Ctrl + C, to copy the file.  

3. On the Windows desktop, double click the My Documents folder to open it, then 
double-click on websites and finally double click on firstsite. You have now 
navigated to the root of your website. 

4. Create a new folder for your image called images. To do this choose File > New > 
Folder from the menu and name the new folder images.  

5. Double click to open the images folder and choose Edit > Paste, or press Ctrl + V, 
to paste the image file into the folder. 

6. Repeat the Copy/Paste operation on the other image file so that both image files 
are in the firstsite folder. 

Using the Insert Panel 

1. Go back into Dreamweaver and create a new document file by selecting File > 
New from the menu bar or pressing Ctrl + N. Select the Blank Page category and 
HTML and click Create.  

 Give the document the title Inserting Images and save it as images.html  

2. Click on the Image button  on the Common tab of the Insert Panel then choose 
Image from the available drop-down menu options. The Select Image Source 
window opens. 

 



 

Dreamweaver Course Part 2 4 
IT Services, Queen Mary, University of London 

 

2. Navigate to the images folder of your website in the Look in: box and select 
water_lilies_small.jpg from the list of files.  
 
Ensure Preview images is checked and that Relative to is set to Document. 

When you select the image, its dimensions and size are shown in the preview 
section. In this case the image is: 

 150 pixels wide and 113 pixels tall 

 Stored in the JPEG format 

 27 Kilobytes in size which would take a 56K modem 4 seconds to 
download  

4. Click OK.  

5. When prompted, enter some Alternate Text for the image, for example, Picture of 
Water Lillies. This text can be used by speech browsers or any situations where 
images are not loaded for some reason. 

5. Save and preview the page in a web browser.  

Dragging images into the page from the Files panel 

1. In the Files panel, open the images folder and drag the image 
water_lilies_small.jpg into your document.  

2. When prompted, enter the Alternate Text and click OK. 

 

Further exercises: Try downloading an image from any website by right-clicking 
over an image and choosing Save As  in Internet Explorer, then saving it to  your 
website's images folder. Then try including that image on the page. 
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Task 2: Turning An Image Into A Link 
An image can be a link to a new page, or even another image. Let's link our small  
'thumbnail' image to the larger image. 

1. Make sure you can see water_lilies.jpg in the Local files  view (open the images 
folder if necessary by clicking on the + symbol beside the folder). 

2. In your web page, click on the image to select it, then drag the point-to-file button 
beside the Link box in the Property Inspector over to the water_lilies.jpg file in the 
site tab to link to the larger version of the image 
 

 

3. Save the file and preview in a web browser.  

Try clicking on the image. You should be shown the larger version of the image. 
Click Back to return to the thumbnail. 

Further exercises: Try changing the link so that you go to firstpage.html or 
report.doc. Save and preview in a web browser. Try turning other images you may 
have inserted into links. 
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Task 3: Inserting Tables 
Tables in web pages are supposed to be used to present tabular data, but most of the 
time they are used as a tool for controlling the layout of web documents. 

1. Create a new document tables.html and title it Using Tables. 

2. Click on the Insert Table button on the Common tab of the Insert panel  
or choose Insert > Table 

3. The Insert Table dialogue box will appear. Choose a table of 2 rows down and 2 
columns across with a width of 760 pixels and a border of 1 pixel. 

 

 In the Header section, highlight the Top row option. This identifies the top row of 
our table as a header row and this information could be used by assistive 
technologies (speech browsers, for example).  

Click OK and the outline of the table should appear in your document. 

4. Click in the top left cell and type Photo. Use the tab key to move to the next cell. 
Enter Description. Since this is a header row, the text is centred and bold by 
default. 

5. Drag the water_lilies_small.jpg image into the bottom left hand cell. Click in the 
bottom right cell and type A picture of water lilies. 
 
Note: if you accidentally dragged the larger water lilies image in the table will 
expand to accommodate the picture. When you delete the picture you need to click 
outside of the table for Dreamweaver to redraw the table at the correct size 

6. Save and preview the document in a web browser. 
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Task 4: Modifying A Table 

Cell Padding 

1. Select the table in tables.html by clicking once in the table and choosing Modify > 
Table > Select Table. Alternatively, move the cursor to the top left hand corner of 
the table  until it becomes a four-headed arrow and click.  

2. Once the table is selected, the Property Inspector will have changed to show all the 
properties of the table that can be altered (see below). Make sure the panel is fully 
expanded to see all the properties. 

3. Set Cell Padding to 5. This adds 5 pixels space around the inside of each table cell. 

 

 
Property Inspector after selecting a table 

4. Save and preview in a web browser, then try changing the Cell Padding value to 
see its effect. 

Table width - percentage or grow to accommodate 

1. With the table selected. Change the W value (short for width) on the Property 
Inspector to 100 and change the drop down beside it to %.  

2. Save and preview in a web browser. Try resizing the web browser. Notice how the 
table expands and contracts. 

3. Back in Dreamweaver, select the table. Delete the W value in the Property 
Inspector. 

4. Save and preview in a web browser. The table is now only big enough to 
accommodate the contents of the table. 

5. In Dreamweaver once more, select the table, and revert to a width of 760 pixels. 

Cell padding  
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Task 5: Table Rows And Cells 

1. Select the top table row by moving the cursor to the far left of the top table row 
and clicking (the cursor will turn into a right pointing arrow when it is the correct 
place).  

2. With the row selected, make the row background a light grey by clicking on the 
background colour well (see below) and choosing a grey colour. 

3. With the Property Inspector in CSS mode, make the text of one of the headings 
white by selecting it, and choosing white from the text colour well (see below). 
The new CSS Rule dialogue box will appear. Save the style as a Class called white. 

4.  Apply the Style white to the other heading using the Targetted Rule menu. 

5. Select the Description column by moving the cursor above the column with the 
heading Description and clicking. The cursor will turn into a downward pointing 
arrow when it is in the right position. 

4. Set the vertical alignment of these cells to Top using the drop down menu beside 
Vert in the Property Inspector. 

5. Set the cell width of the Photo column by clicking above the Photo column to 
select it then specifying 150 next to W in the Property Inspector. 

 

 
 

 

7. Save the changes and preview in a browser. 

 Inserting and deleting rows and columns 

There are several ways of inserting or removing rows and columns from tables. 

1. Choose Modify > Table > Insert Row. A row is inserted above the current one. 

1. Choose Modify > Table > Insert Row or Columns . The Insert Rows or 
Columns dialogue box will appear enabling you to add multiple rows or columns. 

 

3. Choose to insert 2 rows below the selection. Click OK 

Cell vertical 
alignment 

Cell width  Background colour 
well 

Text colour well 
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4. Click in the bottom right hand cell of the table and press Tab key to create a new 
row. 

5. To delete a row or column, first select the cells by clicking in one and dragging 
over the rest, then press delete, or choose Edit > Cut (Ctrl + X). 

6. Merge two cells by selecting them as above, then clicking on the Merge cells 
icon in the Property Inspector.  
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Task 6: Setting Up The Remote Server 
In order to ‘publish’ web documents, they need to be uploaded onto a web server 
using the file-transfer protocol (FTP) built into Dreamweaver. This task involves 
adding the web server and transfer details to the existing Site Definition. 

1. Close all your open files and the Styles and Insert panels. 

2. Choose Manage Sites from the Sites menu. 

3. With the site name highlighted, click Edit 

4. Select the Servers option. 

 

 5. Click on the + sign to add a server and add the following details: 

Server Name: Course Web Server 

Connect Using: FTP 

FTP Address: ftp.web.qmul.ac.uk 

Username: use the username given on your PC screen 

Password: use the password on your PC screen 

Root Directory: /other/test1/public/dwcourse/username/ 

 

6. Click on the More Options and check the box alongside Use Passive FTP 



 

Dreamweaver Course Part 2 11 
IT Services, Queen Mary, University of London 

 

 

7. Click Save twice to return to the Site list, then click Done. 

 

At this point Dreamweaver may inform you that it is recreating the site cache. 
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Task 7: Uploading Your New Website 
Before we upload our site, we will expand the Files panel so that we can 
simultaneously view the local files on our computer and the remote files on the web 
server. 

1. Save and close any web pages open in Dreamweaver 

2. In the Files panel, click on the Expand/Collapse button on the toolbar to 
expand the panel. Notice how the Files panel menu bar replaces Dreamweaver's 
normal menu bar.  
 
If you want to get back to Dreamweaver's normal layout, just click on the 
Expand/Collapse button again.  
 
Using the expanded Files panel you can simultaneously see the Remote Server list 
on the left hand side and the Local Files list on the right.  

 

 

 

3. Click on the Connect button  on the toolbar of the expanded Files panel. 
Dreamweaver will attempt to connect to the web server. There shouldn't be any 
files listed in the Remote Server pane yet. 

4. In the Local files pane, click on the top, green Site folder to highlight it and click  
on the Put button . Dreamweaver will ask Are you sure you wish to put the entire 
site? Click OK.  

5. Click on the Expand/Collapse button again to shrink the Files panel back down. 
You can see the remote files even with the panel collapsed by swapping between 
Local View and Remote Server view. 

Connect Refresh 
Local Files List Remote File List Get  Put 
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6. Open a web browser and go to: 

http://www.test1.qmul.ac.uk/dwcourse/ugzz9xx/  

where ugzz9xx is the username specified in the bottom right hand corner of your 
PC desktop.  
 
Notice that because you haven't specified a filename in the web address and there 
is no index.html file, you just see a file listing of the web site. 

8. Open each of the files listed by double-clicking on them to see how they appear in 
the browser and check that links you created in the first session are working.  

9. Go back to Dreamweaver and click once on the file name firstpage.html.  This 
will enable you to rename the file - call it index.html. If there are any links to this 
file in other files, you will be prompted to 'Update files?', so that the links will 
still work. Click Update if asked. 

10. Upload this new index.html file to the web site by highlighting it and clicking on 
the Put button. 

11. Go back to the web browser and reload the web site: 

http://www.test1.qmul.ac.uk/dwcourse/ugzz9xx/ 

Now that you have a file called index.html at the top level of the site, you should 
see that file displayed in the browser window instead of just a file listing. 

Note that if any other files had to be updated because they contain links to the 
firtspage.html, then those updated files will also need to be uploaded if all links 
are to work. 
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Task 8: Editing A Web Page  

1. With the Files panel minimised and in Remote files view, click once on the file 

index.html then click on the Get button.  

2. Dreamweaver may ask whether to Include Dependent Files?.  

 Choose Yes and check Don't show me this message again. 

 Dreamweaver will now always get copies of images, style sheets and javascript 
files necessary to view and edit the web page. 
 
Tip: You can make this dialogue box re-appear by going to Edit > Preferences, 
and clicking in the Site category and then ticking the box Prompt on Get/Check 
Out  

3. Make a small change to the web page. e.g., "I've updated this page!" 

4. Save and preview the document in a web browser. 

5. If you are happy with the change, click on the File Management button  and 
choose Put from the drop down menu. 

 

6. Dreamweaver will ask whether to Include Dependent Files?.  

 Check Don't show me this message again, but this time choose No.  

 Dreamweaver will then only upload the web page you have been editing. We 
suggest you do not ask Dreamweaver to automatically upload all other files 
(images, style sheets and javascript) as a precaution. If you have changed these 
files, you should upload them and download them separately.  
 
Tip: You can get this dialogue box to re-appear by going to Edit > Preferences, 
and clicking in the Site category and tick the box Prompt on Put/Check In. 

7.  Use your web browser to navigate to index.html and make sure the edit is there. 
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Task 9: Publishing And Editing Non-Web Pages 

Adding a new Word document to your website 

1. Create a Word document using Microsoft Word from the Microsoft Office option 
in Start > All Programs menu of the PC.  

2. Type some text and save it as report.doc in your firstsite folder (My Documents > 
websites > firstsite). Close Word 

3. In Dreamweaver, refresh the file list in the Local Files panel by clicking on the 

Refresh button . You should see report.doc listed in your site files.  

4 Click on the Word document and then click on the Put File button to upload the 
Word document. The Word document is now on your website, but there are no 
links on web pages to it. 

5. Open one of your web pages, for example, links.html and add a link to the word 
document, report.doc then save and upload links.html  (Click on the File 

Management button on the Document Toolbar  and choose Put.  

6. Close links.html 

7. Test the revised links.html web page using a web browser.  

 

Editing a Word document on your website 
The copies of Dreamweaver in the training room are configured to be able to open 
Word documents. You can customise which applications Dreamweaver uses to open 
files by going to Edit > Preferences and choosing the File Types / Editors category.  

1. In Dreamweaver, double-click report.doc. Dreamweaver will get the file and open 
it using Word. 

2. Edit the file, save it again and close Word. 

3. In Dreamweaver, click on report.doc and then click on the Put File button on the 
Files tab toolbar. The changed file is uploaded onto your website. 
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Task 10: Using Folders On Your Website 
Folders are a useful way of organising your website. Every folder should have a 
default index.html page.  

1. In the Files tab, click on the menu icon and choose File > New Folder, being 
careful not to choose New File. 
 

   

2. Call the folder students. If you end up with a folder called untitled, right-click 
over the folder and choose Rename. 

3. Right-click on the students folder, choose New File from the pop-up menu and 
call the new file index.html. 

4. Double-click on index.html to open it, give the page the title Student Page and add 
some text like "Student information".  

5. Save your changes and upload index.html (Click on the File Management button 

 on the Document Toolbar and choose Put). Close the file. 

6. Switch to Remote Server view and notice that the folder Students has been created 
containing the index.html file just uploaded. 

7. Go to your web browser and in the Address bar enter: 

http://www.test1.qmul.ac.uk/dwcourse/ugzz9xx/students/index.html  

Linking to folders 
You can create links to folders themselves as well as to files. When a user follows a 
link to a folder they will either see a listing of the files in that folder or, if it exists, the 
index.html file will be displayed. 

1.  Open the index.html file in the site root directory (the one that was originally called 
firstpage.html) by double-clicking on it in the Remote Server view. 

2.  Type 'Go to Students page', highlight it, then use the point-to-file tool in the 
Property Inspector to make a link to the students folder. 

3.  Save and upload index.html (click on the File Management button  on the 
Document Toolbar and choose Put). 
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4.  Open the site’s index.html page in your web browser where you should see the Go 
to Students page link.  

Clicking on this link should display the students/index.html file. 
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Task 11: Editing A Web Page Using Check In And Out 
Check in and Check out is useful in situations where more than one person may be 
maintaining and editing a web site at the same time, as it keeps track of who is 
working on particular files. 

1.  To enable Check in/out: 

 Go to the Site  menu and choose Manage Sites 

 Select your site and click Edit 

 Select the Servers section of the Site Set-up window, highlight Course Web 
Server and click on the pencil Edit icon. 

 Select Advanced and check the option 'Enable file check out' and 'check out 
files when opening' 

 Enter your username for this course in the Check out name box. 

 Click OK then Done. 

2. With the Files tab in Remote files view, click on links.html to highlight it the click 

on the Check out button.   on the Files tab. 

 A small green tick appears beside the file in the Site files list to indicate that it has 
been checked out by you.  

When Dreamweaver 'checks out' a file it: 

 changes our local copy from Read only to Writable 

 downloads a new copy of the file from the website 

 marks the copy on the website as being edited by you 

 it can also download images, style sheets, and javascript required to view and 
edit the web page. 

3. Make another small change to the text of the page.  

4. Save and preview the document in a web browser (F12 or click on the Preview 

button  on the Document toolbar) 

5. If you are happy with the change, click on the File Management button  and 
this time choose Check In. 
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When Dreamweaver Checks in a file it: 

 checks if there are any unsaved changes. If there are, it prompts you whether 
you want to save the file 

 uploads the file to the website 

 unmarks the copy on the website as being edited by you 

 marks the local copy as Read-only 

 it can also upload images, style sheets, and javascript required to view the web 
page 

5. Close the web page. It is very important to close the web page after it is 
checked back in. This is because it is now marked as 'Read only'. 

6. Check that the page has been uploaded successfully by viewing it in your web 
browser. 

 

Editing a Read only or Checked in file 
To demonstrate what happens when an unchecked out file is edited 

1.Open and edit links.html  

2.Check the file back in. Notice a padlock now appears beside links.html in the file list 
in the Files tab 

3.Make another small change to the page and try to save it. 

4.Dreamweaver displays the Save As dialogue box. This is because the file is now 
Read only and can't be overwritten. Click Cancel 

5.If you edit a file that is Read only because it is not checked out, you have two 
options: 

Close the web page, without saving changes, losing any work you've done. 

Choose Turn off Read Only from the File Management button  . You will then be 
able to save and check in the file, but you have evaded the check out / check in 
feature. 

 


